BETA

28th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [28/12/19 01:39 PM] with 'Partial Outage'

Issue has been resolved at [28/12/19 01:40 PM]