BETA

28th December 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [28/12/19 01:19 PM] with 'Major Outage'

Issue has been resolved at [28/12/19 01:29 PM]