BETA

28th December 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [28/12/19 05:19 AM] with 'Partial Outage'

Issue has been resolved at [28/12/19 05:59 AM]