BETA

27th December 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [27/12/19 11:09 AM] with 'Partial Outage'

Issue has been resolved at [27/12/19 11:19 AM]