BETA

27th December 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/12/19 11:09 AM] with 'Major Outage'

Issue has been resolved at [27/12/19 11:19 AM]