BETA

27th December 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [27/12/19 02:49 AM] with 'Partial Outage'

Issue has been resolved at [27/12/19 02:59 AM]