BETA

27th December 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [27/12/19 02:49 AM] with 'Major Outage'

Issue has been resolved at [27/12/19 02:59 AM]