BETA

26th December 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [26/12/19 03:39 PM] with 'Major Outage'

Issue has been resolved at [26/12/19 05:49 PM]