BETA

26th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [26/12/19 01:09 PM] with 'Partial Outage'

Issue has been resolved at [26/12/19 01:19 PM]