BETA

26th December 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [26/12/19 12:49 PM] with 'Major Outage'

Issue has been resolved at [26/12/19 12:59 PM]