BETA

25th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [25/12/19 03:39 PM] with 'Partial Outage'

Issue has been resolved at [25/12/19 03:49 PM]