BETA

1st June 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/06/17 12:11 AM] with 'Partial Outage'

Issue has been resolved at [01/06/17 12:13 AM]