BETA

24th December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [24/12/19 12:49 PM] with 'Major Outage'

Issue has been resolved at [24/12/19 01:40 PM]