BETA

23rd December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/12/19 05:44 PM] with 'Partial Outage'

Issue has been resolved at [23/12/19 05:54 PM]