BETA

23rd December 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [23/12/19 04:35 PM] with 'Partial Outage'

Issue has been resolved at [23/12/19 04:44 PM]