BETA

23rd December 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [23/12/19 04:15 PM] with 'Major Outage'

Issue has been resolved at [23/12/19 04:24 PM]