BETA

23rd December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [23/12/19 01:44 PM] with 'Major Outage'

Issue has been resolved at [23/12/19 01:54 PM]