BETA

23rd December 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [23/12/19 01:15 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [23/12/19 04:34 PM]