BETA

21st December 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [21/12/19 01:14 PM] with 'Partial Outage'

Issue has been resolved at [21/12/19 02:34 PM]