BETA

21st December 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [21/12/19 12:24 AM] with 'Partial Outage'

Issue has been resolved at [21/12/19 12:34 AM]