BETA

31st May 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [31/05/17 11:56 PM] with 'Major Outage'

Issue has been resolved at [01/06/17 12:01 AM]