BETA

20th December 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [20/12/19 09:45 AM] with 'Partial Outage'

Issue has been resolved at [20/12/19 09:54 AM]