BETA

31st May 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [31/05/17 11:47 PM] with 'Major Outage'

Issue has been resolved at [31/05/17 11:52 PM]