BETA

17th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [17/12/19 12:50 PM] with 'Partial Outage'

Issue has been resolved at [17/12/19 12:59 PM]