BETA

17th December 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [17/12/19 12:30 PM] with 'Partial Outage'

Issue has been resolved at [17/12/19 12:40 PM]