BETA

16th December 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [16/12/19 01:20 PM] with 'Partial Outage'

Issue has been resolved at [16/12/19 02:30 PM]