BETA

16th December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [16/12/19 01:11 PM] with 'Major Outage'

Issue has been resolved at [16/12/19 02:31 PM]