BETA

16th December 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [16/12/19 01:11 PM] with 'Major Outage'

Issue has been resolved at [16/12/19 02:30 PM]