BETA

16th December 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/12/19 01:10 PM] with 'Major Outage'

Issue has been resolved at [16/12/19 02:30 PM]