BETA

15th December 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [15/12/19 11:30 PM] with 'Partial Outage'

Issue has been resolved at [15/12/19 11:40 PM]