BETA

15th December 2019

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [15/12/19 01:30 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/12/19 03:30 PM]