BETA

15th December 2019

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [15/12/19 01:50 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/12/19 03:00 AM]