BETA

14th December 2019

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [14/12/19 12:50 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/12/19 01:20 PM]