BETA

14th December 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/12/19 12:00 PM] with 'Major Outage'

Issue has been resolved at [14/12/19 12:10 PM]