BETA

16th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/03/19 12:53 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/03/19 01:02 PM]