BETA

13th December 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [13/12/19 08:10 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 08:20 PM]