BETA

13th December 2019

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [13/12/19 07:40 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 07:50 PM]