BETA

13th December 2019

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [13/12/19 06:50 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 07:00 PM]