BETA

13th December 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [13/12/19 05:40 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 06:00 PM]