BETA

13th December 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [13/12/19 05:00 PM] with 'Partial Outage'

Issue has been resolved at [13/12/19 05:10 PM]