BETA

31st May 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [31/05/17 11:44 PM] with 'Major Outage'

Issue has been resolved at [01/06/17 12:05 AM]