BETA

13th December 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [13/12/19 04:40 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 04:50 PM]