BETA

13th December 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [13/12/19 04:30 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/12/19 05:20 PM]