BETA

13th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [13/12/19 04:20 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/12/19 05:40 PM]