BETA

13th December 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [13/12/19 02:49 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 02:59 PM]