BETA

31st May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [31/05/17 11:43 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/06/17 12:01 AM]