BETA

13th December 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [13/12/19 12:30 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 12:40 PM]