BETA

13th December 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [13/12/19 12:10 PM] with 'Major Outage'

Issue has been resolved at [13/12/19 12:20 PM]