BETA

13th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [13/12/19 12:00 PM] with 'Partial Outage'

Issue has been resolved at [13/12/19 12:10 PM]