BETA

26th July 2016

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [26/07/16 07:29 AM] with 'Major Outage'

Issue has been resolved at [26/07/16 07:30 AM]